Little trouble with Aves Apoxie Sculpt... Doesnt dry.
Other Forums: Action Figure Chatter, Figure Realm Comments and Questions, Identify Help, Off Topic, Trading Post

Little trouble with Aves Apoxie Sculpt... Doesnt dry.

Posted in Custom Workstation

So I sculpted a part on a figure, days later I accidentally broke part of it off. When tryin to repair it, the apoxie doesn't wanna dry, it stays some what hard in the center, and sticky on the outside. I know its not the way I mixed it because I made extra to use on other figures, and they dried perfectly.

Could it be that im using the dried apoxie with the new wet stuff? It still sticks just doesn't dry. I let it sit for 2 days and still no change.

Posted by markiemarky
on Sunday, April 6, 2008
User Comments
markiemarky -
Sunday, April 6, 2008
Yea thats what it was, the part I scraped off is all chalky. I mix some new stuff and its drying perfectly fine.

Thanks
Mikey11935 -
Sunday, April 6, 2008
I agree when mixed correctly you can drop it like 6 feet and not even a scratch. I have had the same issue though and can say its from lack of complete mixing.
markiemarky -
Sunday, April 6, 2008
yea I just scraped it off and im gonna retry it.
Gee_jays_Customs -
Sunday, April 6, 2008
that part probably didn't mix well enough as the others? thats why I mix mine for a while, just to be sure. just a thought tho, I could be wrong.

~Gj
markiemarky -
Sunday, April 6, 2008
Well I know its not the way I mixed it, I made a batch, use part of it for the repair, the rest to work on other figures. the it dried fine, except for the part I've been trying to repair.
18thstreet-Geppetto -
Sunday, April 6, 2008
that happens to me sometimes, but I just go over it with new apoxie, plus it really can be the way you mixed it
Write a new Comment
New Comment...
                                                                  Pictures & Links

 

Thundercats on eBay